Baruwa 2.0.1 - Inbound/outbound queues always empty

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Baruwa 2.0.1 - Inbound/outbound queues always empty

Cedric Betrisey
Hi,

Since my setup with baruwa 2.0.1 is working with exim. I have mailscanner
pointing properly to the inbound/outbound queues of exim.

But, the UI is still showing no emails, even if some of them are in the queue.

How to get the incoming/outgoing messages queue working/displaying the emails
queued in baruwa ?

Thx a lot in adv.
Cheers
Cedric


_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Baruwa 2.0.1 - Inbound/outbound queues always empty

jeremymcs
You are missing the cronjobs which run.

https://www.baruwa.org/docs/2.0/community/install.html#step-6c-install-cronjobs-and-sudo-file


--
Jeremy McSpadden
Flux Labs, Inc | http://www.fluxlabs.net | Endless Solutions
Office : 850-250-5590x101 | Cell : 850-890-2543 | Fax : 850-254-2955

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Cedric Betrisey
Sent: Tuesday, August 27, 2013 7:29 PM
To: [hidden email]
Subject: [Baruwa] Baruwa 2.0.1 - Inbound/outbound queues always empty

Hi,

Since my setup with baruwa 2.0.1 is working with exim. I have mailscanner pointing properly to the inbound/outbound queues of exim.

But, the UI is still showing no emails, even if some of them are in the queue.

How to get the incoming/outgoing messages queue working/displaying the emails queued in baruwa ?

Thx a lot in adv.
Cheers
Cedric


_______________________________________________
http://pledgie.com/campaigns/12056



_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Baruwa 2.0.1 - Inbound/outbound queues always empty

Cedric Betrisey
In reply to this post by Cedric Betrisey
Cedric Betrisey <cedric@...> writes:

>
> Hi,
>
> Since my setup with baruwa 2.0.1 is working with exim. I have mailscanner
> pointing properly to the inbound/outbound queues of exim.
>
> But, the UI is still showing no emails, even if some of them are in the
queue.
>
> How to get the incoming/outgoing messages queue working/displaying the
emails

> queued in baruwa ?
>
> Thx a lot in adv.
> Cheers
> Cedric
>
> _______________________________________________
> http://pledgie.com/campaigns/12056
>
>

Thanks.

The problem is not that.. All jobs are set properly. In fact the problem is
coming from fact that anytime the machine is rebooted, the /var/lock/baruwa
directory is deleted. Because of that, the queuestats cron job cannot run
and gets failed to update the stats.

Any idea why /var/lock/baruwa is everytime getting deleted after a hard
reboot of the serves ?

CHeers
Cedric



_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Baruwa 2.0.1 - Inbound/outbound queues always empty

Cedric Betrisey
In reply to this post by jeremymcs
Jeremy McSpadden <jeremy@...> writes:

>
> You are missing the cronjobs which run.
>
> https://www.baruwa.org/docs/2.0/community/install.html#step-6c-install-
cronjobs-and-sudo-file

>
> --
> Jeremy McSpadden
> Flux Labs, Inc | http://www.fluxlabs.net | Endless Solutions
> Office : 850-250-5590x101 | Cell : 850-890-2543 | Fax : 850-254-2955
>
> -----Original Message-----
> From: baruwa-bounces@...
> [mailto:baruwa-bounces@...] On Behalf Of Cedric Betrisey
> Sent: Tuesday, August 27, 2013 7:29 PM
> To: baruwa@...
> Subject: [Baruwa] Baruwa 2.0.1 - Inbound/outbound queues always empty
>
> Hi,
>
> Since my setup with baruwa 2.0.1 is working with exim. I have mailscanner
pointing properly to the
> inbound/outbound queues of exim.
>
> But, the UI is still showing no emails, even if some of them are in the
queue.
>
> How to get the incoming/outgoing messages queue working/displaying the
emails queued in baruwa ?

>
> Thx a lot in adv.
> Cheers
> Cedric
>
> _______________________________________________
> http://pledgie.com/campaigns/12056
>
> _______________________________________________
> http://pledgie.com/campaigns/12056
>
>

Thanks Jeremy. As always very usefull support...

The problem is not that.. All jobs are set properly. In fact the problem is
coming from fact that anytime the machine is rebooted, the /var/lock/baruwa
directory is deleted. Because of that, the queuestats cron job cannot run
and gets failed to update the stats.

Any idea why /var/lock/baruwa is everytime getting deleted after a hard
reboot of the serves ? Do we need to setup something in rc.local in order to
recreate those directories after reboot ?

CHeers
Cedric




_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Baruwa 2.0.1 - Inbound/outbound queues always empty

jeremymcs
Those files should be created when Baruwa starts. It looks like a permissions issue. 

--
Jeremy McSpadden
Flux Labs, Inc | http://www.fluxlabs.net | Endless Solutions
Office : <a href="tel:850-250-5590;101" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="2">850-250-5590x101 | Cell : <a href="tel:850-890-2543" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="3">850-890-2543 | Fax : <a href="tel:850-254-2955" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="4">850-254-2955

On Aug 28, 2013, at 2:09 PM, "Cedric Betrisey" <[hidden email]> wrote:

Jeremy McSpadden <jeremy@...> writes:


You are missing the cronjobs which run.

https://www.baruwa.org/docs/2.0/community/install.html#step-6c-install-
cronjobs-and-sudo-file

--
Jeremy McSpadden
Flux Labs, Inc | http://www.fluxlabs.net | Endless Solutions
Office : 850-250-5590x101 | Cell : 850-890-2543 | Fax : 850-254-2955

-----Original Message-----
From: baruwa-bounces@...
[mailto:baruwa-bounces@...] On Behalf Of Cedric Betrisey
Sent: Tuesday, August 27, 2013 7:29 PM
To: baruwa@...
Subject: [Baruwa] Baruwa 2.0.1 - Inbound/outbound queues always empty

Hi,

Since my setup with baruwa 2.0.1 is working with exim. I have mailscanner
pointing properly to the
inbound/outbound queues of exim.

But, the UI is still showing no emails, even if some of them are in the
queue.

How to get the incoming/outgoing messages queue working/displaying the
emails queued in baruwa ?

Thx a lot in adv.
Cheers
Cedric

_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056



Thanks Jeremy. As always very usefull support...

The problem is not that.. All jobs are set properly. In fact the problem is
coming from fact that anytime the machine is rebooted, the /var/lock/baruwa
directory is deleted. Because of that, the queuestats cron job cannot run
and gets failed to update the stats.

Any idea why /var/lock/baruwa is everytime getting deleted after a hard
reboot of the serves ? Do we need to setup something in rc.local in order to
recreate those directories after reboot ?

CHeers
Cedric




_______________________________________________
http://pledgie.com/campaigns/12056


_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Baruwa 2.0.1 - Inbound/outbound queues always empty

Cedric Betrisey
Jeremy McSpadden <jeremy@...> writes:

>
>
> Those files should be created when Baruwa starts. It looks like a
permissions issue. --
> Jeremy McSpadden
> Flux Labs, Inc | http://www.fluxlabs.net | Endless Solutions
> Office : 850-250-5590x101 | Cell : 850-890-2543 |
>  Fax : 850-254-2955
>

Where can I see which perm is missing ? Any log ? I do not saw anything in
celeryd logs ...



_______________________________________________
http://pledgie.com/campaigns/12056