Baruwa Interface stops showing messages

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Baruwa Interface stops showing messages

Adam Gent
Hi,

We have a few Baruwa 2 systems running that were installed using the baruwa-install scripts and have been working well for a few months.

However recently one of our systems got hit by a large amount of spam (up to 25k messages a day), this was fine until a few days ago where it just stopped reporting any new mail in the web interface.
It does still seem to be forwarding email though, it just doesn't show up in the Baruwa interface. Looking in various log files I couldn't see anything that identified any errors.

Any ideas?

Kind Regards,

--
Adam Gent 

_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Baruwa Interface stops showing messages

jeremymcs
Have you verified the services are running ? Bsql is the process you should verify is running. 

--
Jeremy McSpadden | Flux Labs
Local - <a href="tel:850-250-5590;501" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="0/1">850-250-5590x501 | Mobile - <a href="tel:850-890-2543" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="0/2">850-890-2543 
Fax - <a href="tel:850-254-2955" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="0/3">850-254-2955 | Toll Free - <a href="tel:877-699-FLUX" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="0/4">877-699-FLUX
Web - http://www.fluxlabs.net


On Oct 23, 2015, at 7:57 AM, Adam Gent <[hidden email]> wrote:

Hi,

We have a few Baruwa 2 systems running that were installed using the baruwa-install scripts and have been working well for a few months.

However recently one of our systems got hit by a large amount of spam (up to 25k messages a day), this was fine until a few days ago where it just stopped reporting any new mail in the web interface.
It does still seem to be forwarding email though, it just doesn't show up in the Baruwa interface. Looking in various log files I couldn't see anything that identified any errors.

Any ideas?

Kind Regards,

--
Adam Gent 
_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Baruwa Interface stops showing messages

Adam Gent
Hi Jeremy,

Thanks for replying - I don't seem to have a Bsql process (or an init script to start one), Pgsql is running though.
I'm guessing I'm missing something that used to work..!

--
Adam Gent | Direct: +44 (0) 20 3475 6802
Mobile: +44 (0) 7877 230912

Cadence Networks Ltd | http://ccpg.co.uk | +44 (0) 20 3475 6800 x802


From: "Jeremy McSpadden" <[hidden email]>
To: "baruwa" <[hidden email]>
Sent: Friday, 23 October, 2015 13:58:40
Subject: Re: [Baruwa] Baruwa Interface stops showing messages

Have you verified the services are running ? Bsql is the process you should verify is running. 

--
Jeremy McSpadden | Flux Labs
Local - <a href="tel:850-250-5590;501" target="_blank">850-250-5590x501 | Mobile - <a href="tel:850-890-2543" target="_blank">850-890-2543 
Fax - <a href="tel:850-254-2955" target="_blank">850-254-2955 | Toll Free - <a href="tel:877-699-FLUX" target="_blank">877-699-FLUX
Web - http://www.fluxlabs.net


On Oct 23, 2015, at 7:57 AM, Adam Gent <[hidden email]> wrote:

Hi,

We have a few Baruwa 2 systems running that were installed using the baruwa-install scripts and have been working well for a few months.

However recently one of our systems got hit by a large amount of spam (up to 25k messages a day), this was fine until a few days ago where it just stopped reporting any new mail in the web interface.
It does still seem to be forwarding email though, it just doesn't show up in the Baruwa interface. Looking in various log files I couldn't see anything that identified any errors.

Any ideas?

Kind Regards,

--
Adam Gent 
_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Baruwa Interface stops showing messages

jeremymcs
It starts with baruwa init. That is what does the sql injections into the db. Try starting baruwa manually via pasted to get an output in the console. See if you have any errors. 

--
Jeremy McSpadden | Flux Labs
Local - <a href="tel:850-250-5590;501" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="0/1">850-250-5590x501 | Mobile - <a href="tel:850-890-2543" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="0/2">850-890-2543 
Fax - <a href="tel:850-254-2955" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="0/3">850-254-2955 | Toll Free - <a href="tel:877-699-FLUX" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="0/4">877-699-FLUX
Web - http://www.fluxlabs.net


On Oct 23, 2015, at 8:46 AM, Adam Gent <[hidden email]> wrote:

Hi Jeremy,

Thanks for replying - I don't seem to have a Bsql process (or an init script to start one), Pgsql is running though.
I'm guessing I'm missing something that used to work..!

--
Adam Gent | Direct: +44 (0) 20 3475 6802
Mobile: +44 (0) 7877 230912

Cadence Networks Ltd | http://ccpg.co.uk | +44 (0) 20 3475 6800 x802


From: "Jeremy McSpadden" <[hidden email]>
To: "baruwa" <[hidden email]>
Sent: Friday, 23 October, 2015 13:58:40
Subject: Re: [Baruwa] Baruwa Interface stops showing messages

Have you verified the services are running ? Bsql is the process you should verify is running. 

--
Jeremy McSpadden | Flux Labs
Local - <a href="tel:850-250-5590;501" target="_blank">850-250-5590x501 | Mobile - <a href="tel:850-890-2543" target="_blank">850-890-2543 
Fax - <a href="tel:850-254-2955" target="_blank">850-254-2955 | Toll Free - <a href="tel:877-699-FLUX" target="_blank">877-699-FLUX
Web - http://www.fluxlabs.net


On Oct 23, 2015, at 7:57 AM, Adam Gent <[hidden email]> wrote:

Hi,

We have a few Baruwa 2 systems running that were installed using the baruwa-install scripts and have been working well for a few months.

However recently one of our systems got hit by a large amount of spam (up to 25k messages a day), this was fine until a few days ago where it just stopped reporting any new mail in the web interface.
It does still seem to be forwarding email though, it just doesn't show up in the Baruwa interface. Looking in various log files I couldn't see anything that identified any errors.

Any ideas?

Kind Regards,

--
Adam Gent 
_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056
_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Baruwa Interface stops showing messages

jeremymcs
paster*

--
Jeremy McSpadden | Flux Labs
Local - <a href="tel:850-250-5590;501" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="0/1">850-250-5590x501 | Mobile - <a href="tel:850-890-2543" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="0/2">850-890-2543 
Fax - <a href="tel:850-254-2955" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="0/3">850-254-2955 | Toll Free - <a href="tel:877-699-FLUX" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="0/4">877-699-FLUX
Web - http://www.fluxlabs.net


On Oct 23, 2015, at 8:49 AM, Jeremy McSpadden <[hidden email]> wrote:

It starts with baruwa init. That is what does the sql injections into the db. Try starting baruwa manually via pasted to get an output in the console. See if you have any errors. 

--
Jeremy McSpadden | Flux Labs
Local - <a href="tel:850-250-5590;501" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="0/1">850-250-5590x501 | Mobile - <a href="tel:850-890-2543" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="0/2">850-890-2543 
Fax - <a href="tel:850-254-2955" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="0/3">850-254-2955 | Toll Free - <a href="tel:877-699-FLUX" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="0/4">877-699-FLUX
Web - http://www.fluxlabs.net


On Oct 23, 2015, at 8:46 AM, Adam Gent <[hidden email]> wrote:

Hi Jeremy,

Thanks for replying - I don't seem to have a Bsql process (or an init script to start one), Pgsql is running though.
I'm guessing I'm missing something that used to work..!

--
Adam Gent | Direct: +44 (0) 20 3475 6802
Mobile: +44 (0) 7877 230912

Cadence Networks Ltd | http://ccpg.co.uk | +44 (0) 20 3475 6800 x802


From: "Jeremy McSpadden" <[hidden email]>
To: "baruwa" <[hidden email]>
Sent: Friday, 23 October, 2015 13:58:40
Subject: Re: [Baruwa] Baruwa Interface stops showing messages

Have you verified the services are running ? Bsql is the process you should verify is running. 

--
Jeremy McSpadden | Flux Labs
Local - <a href="tel:850-250-5590;501" target="_blank">850-250-5590x501 | Mobile - <a href="tel:850-890-2543" target="_blank">850-890-2543 
Fax - <a href="tel:850-254-2955" target="_blank">850-254-2955 | Toll Free - <a href="tel:877-699-FLUX" target="_blank">877-699-FLUX
Web - http://www.fluxlabs.net


On Oct 23, 2015, at 7:57 AM, Adam Gent <[hidden email]> wrote:

Hi,

We have a few Baruwa 2 systems running that were installed using the baruwa-install scripts and have been working well for a few months.

However recently one of our systems got hit by a large amount of spam (up to 25k messages a day), this was fine until a few days ago where it just stopped reporting any new mail in the web interface.
It does still seem to be forwarding email though, it just doesn't show up in the Baruwa interface. Looking in various log files I couldn't see anything that identified any errors.

Any ideas?

Kind Regards,

--
Adam Gent 
_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056
_______________________________________________
http://pledgie.com/campaigns/12056
_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Baruwa Interface stops showing messages

Adam Gent
Hi Jeremy,

The output when running (paster celeryd /etc/baruwa/production.ini -f /var/log/baruwa/celeryd.log) is at this pastebin;

http://pastebin.com/uNHB2Lsk

It looks to start OK, there are no errors (just the process running) after the bottom line, it doesn't quit or exit.

Kind Regards,

--
Adam Gent


From: "Jeremy McSpadden" <[hidden email]>
To: "baruwa" <[hidden email]>
Sent: Friday, 23 October, 2015 14:50:38
Subject: Re: [Baruwa] Baruwa Interface stops showing messages

paster*

--
Jeremy McSpadden | Flux Labs
Local - <a href="tel:850-250-5590;501" target="_blank">850-250-5590x501 | Mobile - <a href="tel:850-890-2543" target="_blank">850-890-2543 
Fax - <a href="tel:850-254-2955" target="_blank">850-254-2955 | Toll Free - <a href="tel:877-699-FLUX" target="_blank">877-699-FLUX
Web - http://www.fluxlabs.net


On Oct 23, 2015, at 8:49 AM, Jeremy McSpadden <[hidden email]> wrote:

It starts with baruwa init. That is what does the sql injections into the db. Try starting baruwa manually via pasted to get an output in the console. See if you have any errors. 

--
Jeremy McSpadden | Flux Labs
Local - <a href="tel:850-250-5590;501" target="_blank">850-250-5590x501 | Mobile - <a href="tel:850-890-2543" target="_blank">850-890-2543 
Fax - <a href="tel:850-254-2955" target="_blank">850-254-2955 | Toll Free - <a href="tel:877-699-FLUX" target="_blank">877-699-FLUX
Web - http://www.fluxlabs.net


On Oct 23, 2015, at 8:46 AM, Adam Gent <[hidden email]> wrote:

Hi Jeremy,

Thanks for replying - I don't seem to have a Bsql process (or an init script to start one), Pgsql is running though.
I'm guessing I'm missing something that used to work..!

--
Adam Gent | Direct: +44 (0) 20 3475 6802
Mobile: +44 (0) 7877 230912

Cadence Networks Ltd | http://ccpg.co.uk | +44 (0) 20 3475 6800 x802


From: "Jeremy McSpadden" <[hidden email]>
To: "baruwa" <[hidden email]>
Sent: Friday, 23 October, 2015 13:58:40
Subject: Re: [Baruwa] Baruwa Interface stops showing messages

Have you verified the services are running ? Bsql is the process you should verify is running. 

--
Jeremy McSpadden | Flux Labs
Local - <a href="tel:850-250-5590;501" target="_blank">850-250-5590x501 | Mobile - <a href="tel:850-890-2543" target="_blank">850-890-2543 
Fax - <a href="tel:850-254-2955" target="_blank">850-254-2955 | Toll Free - <a href="tel:877-699-FLUX" target="_blank">877-699-FLUX
Web - http://www.fluxlabs.net


On Oct 23, 2015, at 7:57 AM, Adam Gent <[hidden email]> wrote:

Hi,

We have a few Baruwa 2 systems running that were installed using the baruwa-install scripts and have been working well for a few months.

However recently one of our systems got hit by a large amount of spam (up to 25k messages a day), this was fine until a few days ago where it just stopped reporting any new mail in the web interface.
It does still seem to be forwarding email though, it just doesn't show up in the Baruwa interface. Looking in various log files I couldn't see anything that identified any errors.

Any ideas?

Kind Regards,

--
Adam Gent 
_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056
_______________________________________________
http://pledgie.com/campaigns/12056
_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056