Baruwa on Ubuntu 14.04

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Baruwa on Ubuntu 14.04

jvangent

Hi,

 

Tried to install Baruwa on 14.04. There were some minor problems, but I did manage to install Baruwa and access the website.

 

Now if I add a correct scanning node (using the correct FQDN) I get a 500 when I try to access the status page. If I log out and try to login again, I get the same 500 error.

 

If I manually delete the scanning node from the DB, I can again login and use the Baruwa web interface.

 

The following is shown in celeryd.log:

 

 'ModuleWrapper' object has no attribute 'error'

 

And in Baruwa-error-log:

 

Error - <type 'exceptions.AttributeError'>: 'ModuleWrapper' object has no attribute 'error', referer:

 

I am guessing some of the packages will need to be downgraded, the question is which.

 

 


_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Baruwa on Ubuntu 14.04

admin-at-extremeshok-dot-com
Your going to have endless issues with Ubuntu as a server os.

Use centos 6.5 and you will have very few issues.

If you want something Ubuntu like use Debian 7

Sent from my iPhone

On 19 Sep 2014, at 3:39 PM, Jacco van Gent <[hidden email]> wrote:

Hi,

 

Tried to install Baruwa on 14.04. There were some minor problems, but I did manage to install Baruwa and access the website.

 

Now if I add a correct scanning node (using the correct FQDN) I get a 500 when I try to access the status page. If I log out and try to login again, I get the same 500 error.

 

If I manually delete the scanning node from the DB, I can again login and use the Baruwa web interface.

 

The following is shown in celeryd.log:

 

 'ModuleWrapper' object has no attribute 'error'

 

And in Baruwa-error-log:

 

Error - <type 'exceptions.AttributeError'>: 'ModuleWrapper' object has no attribute 'error', referer:

 

I am guessing some of the packages will need to be downgraded, the question is which.

 

 

_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Baruwa on Ubuntu 14.04

jvangent
Nah, I run centos at work. At home I am already running lts 12.04 perfectly, just want to move up to the next lts. Should be possible. I am close, it is probably one of the packages that is to recent.

Verzonden met mijn Windows Phone

Van: [hidden email]
Verzonden: ‎19-‎9-‎2014 17:27
Aan: [hidden email]
Onderwerp: Re: [Baruwa] Baruwa on Ubuntu 14.04

Your going to have endless issues with Ubuntu as a server os.

Use centos 6.5 and you will have very few issues.

If you want something Ubuntu like use Debian 7

Sent from my iPhone

On 19 Sep 2014, at 3:39 PM, Jacco van Gent <[hidden email]> wrote:

Hi,

 

Tried to install Baruwa on 14.04. There were some minor problems, but I did manage to install Baruwa and access the website.

 

Now if I add a correct scanning node (using the correct FQDN) I get a 500 when I try to access the status page. If I log out and try to login again, I get the same 500 error.

 

If I manually delete the scanning node from the DB, I can again login and use the Baruwa web interface.

 

The following is shown in celeryd.log:

 

 'ModuleWrapper' object has no attribute 'error'

 

And in Baruwa-error-log:

 

Error - <type 'exceptions.AttributeError'>: 'ModuleWrapper' object has no attribute 'error', referer:

 

I am guessing some of the packages will need to be downgraded, the question is which.

 

 

_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Baruwa on Ubuntu 14.04

admin-at-extremeshok-dot-com
Let us know how u go,

I would be interested in adding support for Ubuntu 14.04 my installer.

Sent from my iPhone

On 19 Sep 2014, at 6:35 PM, Jacco van Gent <[hidden email]> wrote:

Nah, I run centos at work. At home I am already running lts 12.04 perfectly, just want to move up to the next lts. Should be possible. I am close, it is probably one of the packages that is to recent.

Verzonden met mijn Windows Phone

Van: [hidden email]
Verzonden: ‎19-‎9-‎2014 17:27
Aan: [hidden email]
Onderwerp: Re: [Baruwa] Baruwa on Ubuntu 14.04

Your going to have endless issues with Ubuntu as a server os.

Use centos 6.5 and you will have very few issues.

If you want something Ubuntu like use Debian 7

Sent from my iPhone

On 19 Sep 2014, at 3:39 PM, Jacco van Gent <[hidden email]> wrote:

Hi,

 

Tried to install Baruwa on 14.04. There were some minor problems, but I did manage to install Baruwa and access the website.

 

Now if I add a correct scanning node (using the correct FQDN) I get a 500 when I try to access the status page. If I log out and try to login again, I get the same 500 error.

 

If I manually delete the scanning node from the DB, I can again login and use the Baruwa web interface.

 

The following is shown in celeryd.log:

 

 'ModuleWrapper' object has no attribute 'error'

 

And in Baruwa-error-log:

 

Error - <type 'exceptions.AttributeError'>: 'ModuleWrapper' object has no attribute 'error', referer:

 

I am guessing some of the packages will need to be downgraded, the question is which.

 

 

_______________________________________________
http://pledgie.com/campaigns/12056
_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Baruwa on Ubuntu 14.04

Andy Thomson
Hey, I just noticed this message (joined the mailing list a few weeks ago, and only just realised my mail client was filtering the messages)

This is probably old news by now, but if you are still stuck, I have a mostly working baruwa install on 14.04.  There were a number of modules that needed downgrading to get it running, but for the particular issue you are having, (500 error after adding scanning node) the issue is with the psutil module being accessed by baruwa/lib/misc.py.

celeryd.log will show something like this.

 File "/home/baruwa/px/local/lib/python2.7/site-packages/baruwa/lib/misc.py", line 70, in get_processes

    except psutil.error.AccessDenied:

    AttributeError: 'ModuleWrapper' object has no attribute 'error' 

This is due to an interface change in psutil.  You could downgrade the module, but I found the code changes simple enough to make it work with the current version.

The changes are psutil.error.AccessDenied becomes psutil.AccessDenied, and process.name becomes process.name(), so just make get_processes look like this:

   def get_processes(process_name):

   "Gets running processes by process name"

   count = 0

   for process in psutil.process_iter():

       try:

           if (process.name() == process_name or

               process.name().startswith(process_name)):

               count += 1

       except psutil.AccessDenied:

           pass

   return count

Cheers
Andy.


--
Andy Thomson
Snr Tech Consultant
Qirx
0431 121 868


From: [hidden email]
To: "Baruwa users list" <[hidden email]>
Sent: Saturday, 20 September, 2014 6:28:27 AM
Subject: Re: [Baruwa] Baruwa on Ubuntu 14.04

Let us know how u go,

I would be interested in adding support for Ubuntu 14.04 my installer.

Sent from my iPhone

On 19 Sep 2014, at 6:35 PM, Jacco van Gent <[hidden email]> wrote:

Nah, I run centos at work. At home I am already running lts 12.04 perfectly, just want to move up to the next lts. Should be possible. I am close, it is probably one of the packages that is to recent.

Verzonden met mijn Windows Phone

Van: [hidden email]
Verzonden: ‎19-‎9-‎2014 17:27
Aan: [hidden email]
Onderwerp: Re: [Baruwa] Baruwa on Ubuntu 14.04

Your going to have endless issues with Ubuntu as a server os.

Use centos 6.5 and you will have very few issues.

If you want something Ubuntu like use Debian 7

Sent from my iPhone

On 19 Sep 2014, at 3:39 PM, Jacco van Gent <[hidden email]> wrote:

Hi,

 

Tried to install Baruwa on 14.04. There were some minor problems, but I did manage to install Baruwa and access the website.

 

Now if I add a correct scanning node (using the correct FQDN) I get a 500 when I try to access the status page. If I log out and try to login again, I get the same 500 error.

 

If I manually delete the scanning node from the DB, I can again login and use the Baruwa web interface.

 

The following is shown in celeryd.log:

 

 'ModuleWrapper' object has no attribute 'error'

 

And in Baruwa-error-log:

 

Error - <type 'exceptions.AttributeError'>: 'ModuleWrapper' object has no attribute 'error', referer:

 

I am guessing some of the packages will need to be downgraded, the question is which.

 

 

_______________________________________________
http://pledgie.com/campaigns/12056
_______________________________________________
http://pledgie.com/campaigns/12056

--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.
_______________________________________________
http://pledgie.com/campaigns/12056


_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Baruwa on Ubuntu 14.04

jvangent
Thanks Andy. I haven't looked further into it due to other stuff that needed to be done. Will try your suggested fix once I am back from holiday.

Verzonden met Windows Mail

Van: [hidden email]
Verzonden: ‎vrijdag‎ ‎24‎ ‎oktober‎ ‎2014 ‎06‎:‎26
Aan: [hidden email]

Hey, I just noticed this message (joined the mailing list a few weeks ago, and only just realised my mail client was filtering the messages)

This is probably old news by now, but if you are still stuck, I have a mostly working baruwa install on 14.04.  There were a number of modules that needed downgrading to get it running, but for the particular issue you are having, (500 error after adding scanning node) the issue is with the psutil module being accessed by baruwa/lib/misc.py.

celeryd.log will show something like this.

 File "/home/baruwa/px/local/lib/python2.7/site-packages/baruwa/lib/misc.py", line 70, in get_processes

    except psutil.error.AccessDenied:

    AttributeError: 'ModuleWrapper' object has no attribute 'error' 

This is due to an interface change in psutil.  You could downgrade the module, but I found the code changes simple enough to make it work with the current version.

The changes are psutil.error.AccessDenied becomes psutil.AccessDenied, and process.name becomes process.name(), so just make get_processes look like this:

   def get_processes(process_name):

   "Gets running processes by process name"

   count = 0

   for process in psutil.process_iter():

       try:

           if (process.name() == process_name or

               process.name().startswith(process_name)):

               count += 1

       except psutil.AccessDenied:

           pass

   return count

Cheers
Andy.


--
Andy Thomson
Snr Tech Consultant
Qirx
0431 121 868


From: [hidden email]
To: "Baruwa users list" <[hidden email]>
Sent: Saturday, 20 September, 2014 6:28:27 AM
Subject: Re: [Baruwa] Baruwa on Ubuntu 14.04

Let us know how u go,

I would be interested in adding support for Ubuntu 14.04 my installer.

Sent from my iPhone

On 19 Sep 2014, at 6:35 PM, Jacco van Gent <[hidden email]> wrote:

Nah, I run centos at work. At home I am already running lts 12.04 perfectly, just want to move up to the next lts. Should be possible. I am close, it is probably one of the packages that is to recent.

Verzonden met mijn Windows Phone

Van: [hidden email]
Verzonden: ‎19-‎9-‎2014 17:27
Aan: [hidden email]
Onderwerp: Re: [Baruwa] Baruwa on Ubuntu 14.04

Your going to have endless issues with Ubuntu as a server os.

Use centos 6.5 and you will have very few issues.

If you want something Ubuntu like use Debian 7

Sent from my iPhone

On 19 Sep 2014, at 3:39 PM, Jacco van Gent <[hidden email]> wrote:

Hi,

 

Tried to install Baruwa on 14.04. There were some minor problems, but I did manage to install Baruwa and access the website.

 

Now if I add a correct scanning node (using the correct FQDN) I get a 500 when I try to access the status page. If I log out and try to login again, I get the same 500 error.

 

If I manually delete the scanning node from the DB, I can again login and use the Baruwa web interface.

 

The following is shown in celeryd.log:

 

 'ModuleWrapper' object has no attribute 'error'

 

And in Baruwa-error-log:

 

Error - <type 'exceptions.AttributeError'>: 'ModuleWrapper' object has no attribute 'error', referer:

 

I am guessing some of the packages will need to be downgraded, the question is which.

 

 

_______________________________________________
http://pledgie.com/campaigns/12056
_______________________________________________
http://pledgie.com/campaigns/12056

--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.
_______________________________________________
http://pledgie.com/campaigns/12056


_______________________________________________
http://pledgie.com/campaigns/12056