Installation Error

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Installation Error

Jorge A Arenas Quezada

Hi and Happy new Year from Mexico

 

I have a problem and hope someone can point me in the right direction

 

I am installing Baruwa 2.0.1 on Centos 6.6 x64

 

But I am getting an error when execute the command paster …

 

The error mention  “Paste 1.7.5.1 is installed but Paste>1.7 is required by ['repoze.what']”

 

The paste version installed is what requierements.txt install automatically

 

I suppose mean I need a paste lower than 1.7.5.1 but above 1.7 … can someone help me with the correct version

 

The command executed is:

 

px/bin/paster make-config baruwa production.ini

 

and the error:

 

Traceback (most recent call last):

  File "px/bin/paster", line 9, in <module>

    load_entry_point('PasteScript==1.7.5', 'console_scripts', 'paster')()

  File "/home/baruwa/px/lib/python2.6/site-packages/paste/script/command.py", line 104, in run

    invoke(command, command_name, options, args[1:])

  File "/home/baruwa/px/lib/python2.6/site-packages/paste/script/command.py", line 143, in invoke

    exit_code = runner.run(args)

  File "/home/baruwa/px/lib/python2.6/site-packages/paste/script/appinstall.py", line 68, in run

    return super(AbstractInstallCommand, self).run(new_args)

  File "/home/baruwa/px/lib/python2.6/site-packages/paste/script/command.py", line 238, in run

    result = self.command()

  File "/home/baruwa/px/lib/python2.6/site-packages/paste/script/appinstall.py", line 295, in command

    self.distro, self.options.ep_group, self.options.ep_name)

  File "/home/baruwa/px/lib/python2.6/site-packages/paste/script/appinstall.py", line 234, in get_installer

    'paste.app_install', ep_name)

  File "/home/baruwa/px/lib/python2.6/site-packages/pkg_resources/__init__.py", line 2569, in load_entry_point

    return ep.load()

  File "/home/baruwa/px/lib/python2.6/site-packages/pkg_resources/__init__.py", line 2258, in load

    self.require(env, installer)

  File "/home/baruwa/px/lib/python2.6/site-packages/pkg_resources/__init__.py", line 2272, in require

    items = working_set.resolve(reqs, env, installer)

  File "/home/baruwa/px/lib/python2.6/site-packages/pkg_resources/__init__.py", line 767, in resolve

    raise VersionConflict(tmpl % args)

pkg_resources.VersionConflict: Paste 1.7.5.1 is installed but Paste>1.7 is required by ['repoze.what']

 

 

 

thanks in advance

 

Jorge Arenas

 


_______________________________________________
http://pledgie.com/campaigns/12056