Large Delays in message processing for Baruwa 2.0 Community

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Large Delays in message processing for Baruwa 2.0 Community

ManicD
Can Anyone point me in the right direction to figure out why messages take so long to pass through the server, some are taking 15 mins, right now the server is not doing anything except the odd one or two test emails so very little load.


=====

2014-10-09 12:29:25 Start queue run: pid=14205
2014-10-09 12:29:27 1XcBqT-0003bV-Qy => user@maildomain.com R=deliver_clean_norandomized T=remote_smtp H=server1.xxxxxxxx.com [xxxxxxxxxxxxxxxx] X=TLSv1:DHE-RSA-AES256-SHA:256 C="250 ok 1412854167 qp 25830"
2014-10-09 12:29:27 1XcBqT-0003bV-Qy Completed
2014-10-09 12:29:27 End queue run: pid=14205
2014-10-09 12:30:12 1XcBvA-0003iH-T5 <= user@maildomain.com H=(me) [xxxxxxxxxxxxxxxxx] P=esmtp S=2616 id=00b301cfe3b4$5fc0c100$1f424300$@mail.com
2014-10-09 12:30:13 1XcBvA-0003iH-T5 == user@maildomain.com R=message_checks defer (-1): queued for message checks
2014-10-09 12:33:21 Start queue run: pid=14519
2014-10-09 12:33:23 1XcBvA-0003iH-T5 => user@maildomain.com R=deliver_clean_norandomized T=remote_smtp H=server1.xxxxxxxxxxxx.com [xxxxxxxxxxxxxxx] X=TLSv1:DHE-RSA-AES256-SHA:256 C="250 ok 1412854403 qp 27086"
2014-10-09 12:33:23 1XcBvA-0003iH-T5 Completed
2014-10-09 12:33:23 End queue run: pid=14519
2014-10-09 12:35:50 Start queue run: pid=14720
2014-10-09 12:35:50 End queue run: pid=14720
2014-10-09 12:36:38 1XcC1O-0003qi-Cm <= user@maildomain.com H=(me) [xxxxxxxxxxxxx] P=esmtp S=2616 id=00bb01cfe3b5$45834410$d089cc30$@maildomain.com
2014-10-09 12:36:38 1XcC1O-0003qi-Cm == user@mailmaildomain.com R=message_checks defer (-1): queued for message checks
==============================
=====NOTE THE HUGE TIME GAP=====
==============================
2014-10-09 12:44:25 Start queue run: pid=15359
2014-10-09 12:44:26 1XcC1O-0003qi-Cm => user@maildomain.com R=deliver_clean_norandomized T=remote_smtp H=server1.xxxxxxxxxxxx.com [xxxxxxxxxxxxxxxx] X=TLSv1:DHE-RSA-AES256-SHA:256 C="250 ok 1412855066 qp 30166"
2014-10-09 12:44:26 1XcC1O-0003qi-Cm Completed
2014-10-09 12:44:26 End queue run: pid=15359

=====

Any Ideas
Reply | Threaded
Open this post in threaded view
|

Re: Large Delays in message processing for Baruwa 2.0 Community

jeremymcs
Is mailscanner running in batch mode ?

--
Jeremy McSpadden
Flux Labs | http://www.fluxlabs.net | Endless Solutions
Office : <a href="tel:850-250-5590;501">850-250-5590x501 | Cell : <a href="tel:850-890-2543">850-890-2543 | Fax : <a href="tel:850-254-2955">850-254-2955

On Oct 9, 2014, at 10:56 AM, ManicD <[hidden email]> wrote:

Can Anyone point me in the right direction to figure out why messages take so
long to pass through the server, some are taking 15 mins, right now the
server is not doing anything except the odd one or two test emails so very
little load.


=====

2014-10-09 12:29:25 Start queue run: pid=14205
2014-10-09 12:29:27 1XcBqT-0003bV-Qy => [hidden email]
R=deliver_clean_norandomized T=remote_smtp H=server1.xxxxxxxx.com
[xxxxxxxxxxxxxxxx] X=TLSv1:DHE-RSA-AES256-SHA:256 C="250 ok 1412854167 qp
25830"
2014-10-09 12:29:27 1XcBqT-0003bV-Qy Completed
2014-10-09 12:29:27 End queue run: pid=14205
2014-10-09 12:30:12 1XcBvA-0003iH-T5 <= [hidden email] H=(me)
[xxxxxxxxxxxxxxxxx] P=esmtp S=2616
[hidden email]
2014-10-09 12:30:13 1XcBvA-0003iH-T5 == [hidden email] R=message_checks
defer (-1): queued for message checks
2014-10-09 12:33:21 Start queue run: pid=14519
2014-10-09 12:33:23 1XcBvA-0003iH-T5 => [hidden email]
R=deliver_clean_norandomized T=remote_smtp H=server1.xxxxxxxxxxxx.com
[xxxxxxxxxxxxxxx] X=TLSv1:DHE-RSA-AES256-SHA:256 C="250 ok 1412854403 qp
27086"
2014-10-09 12:33:23 1XcBvA-0003iH-T5 Completed
2014-10-09 12:33:23 End queue run: pid=14519
2014-10-09 12:35:50 Start queue run: pid=14720
2014-10-09 12:35:50 End queue run: pid=14720
2014-10-09 12:36:38 1XcC1O-0003qi-Cm <= [hidden email] H=(me)
[xxxxxxxxxxxxx] P=esmtp S=2616
[hidden email]
2014-10-09 12:36:38 1XcC1O-0003qi-Cm == [hidden email]
R=message_checks defer (-1): queued for message checks
==============================
=====NOTE THE HUGE TIME GAP=====
==============================
2014-10-09 12:44:25 Start queue run: pid=15359
2014-10-09 12:44:26 1XcC1O-0003qi-Cm => [hidden email]
R=deliver_clean_norandomized T=remote_smtp H=server1.xxxxxxxxxxxx.com
[xxxxxxxxxxxxxxxx] X=TLSv1:DHE-RSA-AES256-SHA:256 C="250 ok 1412855066 qp
30166"
2014-10-09 12:44:26 1XcC1O-0003qi-Cm Completed
2014-10-09 12:44:26 End queue run: pid=15359

=====

Any Ideas



--
View this message in context: http://baruwa-users-list.963389.n3.nabble.com/Large-Delays-in-message-processing-for-Baruwa-2-0-Community-tp4027463.html
Sent from the Baruwa users list mailing list archive at Nabble.com.

_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Large Delays in message processing for Baruwa 2.0 Community

ManicD
no, its set for queue mode, thats how my other one was set, should i use batch?
Reply | Threaded
Open this post in threaded view
|

Re: Large Delays in message processing for Baruwa 2.0 Community

jeremymcs
Yes, batch is the way you want. 

--
Jeremy McSpadden
Flux Labs | http://www.fluxlabs.net | Endless Solutions
Office : <a href="tel:850-250-5590;501">850-250-5590x501 | Cell : <a href="tel:850-890-2543">850-890-2543 | Fax : <a href="tel:850-254-2955">850-254-2955

On Oct 10, 2014, at 7:49 AM, ManicD <[hidden email]> wrote:

no, its set for queue mode, thats how my other one was set, should i use
batch?



--
View this message in context: http://baruwa-users-list.963389.n3.nabble.com/Large-Delays-in-message-processing-for-Baruwa-2-0-Community-tp4027463p4027465.html
Sent from the Baruwa users list mailing list archive at Nabble.com.

_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Large Delays in message processing for Baruwa 2.0 Community

ManicD
Still seeing the same in batch mode.

Any more ideas?
Reply | Threaded
Open this post in threaded view
|

Re: Large Delays in message processing for Baruwa 2.0 Community

jeremymcs
Track it back in debug mode. 

--
Jeremy McSpadden
Flux Labs | http://www.fluxlabs.net | Endless Solutions
Office : <a href="tel:850-250-5590;501">850-250-5590x501 | Cell : <a href="tel:850-890-2543">850-890-2543 | Fax : <a href="tel:850-254-2955">850-254-2955

On Oct 14, 2014, at 5:43 AM, ManicD <[hidden email]> wrote:

Still seeing the same in batch mode.

Any more ideas?



--
View this message in context: http://baruwa-users-list.963389.n3.nabble.com/Large-Delays-in-message-processing-for-Baruwa-2-0-Community-tp4027463p4027470.html
Sent from the Baruwa users list mailing list archive at Nabble.com.

_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Large Delays in message processing for Baruwa 2.0 Community

ManicD
Can you point me in the right direction with this?
I did enable debug mode in the Settings > MailScanner Settings option and have reviewed every log file i can find but I'm yet to find anything useful.



Also having a problem with low spam not being delivered even though the domain setting says deliver.....might be my next topic but your help with debugging may lead me on my way.
Reply | Threaded
Open this post in threaded view
|

Re: Large Delays in message processing for Baruwa 2.0 Community

admin-at-extremeshok-dot-com
CentOS or Debian or Ubuntu ?

Self install  or using a script ?

On 10/14/2014 5:09 PM, ManicD wrote:

> Can you point me in the right direction with this?
> I did enable debug mode in the Settings > MailScanner Settings option and
> have reviewed every log file i can find but I'm yet to find anything useful.
>
>
>
> Also having a problem with low spam not being delivered even though the
> domain setting says deliver.....might be my next topic but your help with
> debugging may lead me on my way.
>
>
>
> --
> View this message in context: http://baruwa-users-list.963389.n3.nabble.com/Large-Delays-in-message-processing-for-Baruwa-2-0-Community-tp4027463p4027474.html
> Sent from the Baruwa users list mailing list archive at Nabble.com.
>
> _______________________________________________
> http://pledgie.com/campaigns/12056


_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Large Delays in message processing for Baruwa 2.0 Community

jeremymcs
In reply to this post by ManicD
Set debug on in mailscanner.conf then reload mail scanner from ssh. Watch the output. 

--
Jeremy McSpadden
Flux Labs | http://www.fluxlabs.net | Endless Solutions
Office : <a href="tel:850-250-5590;501">850-250-5590x501 | Cell : <a href="tel:850-890-2543">850-890-2543 | Fax : <a href="tel:850-254-2955">850-254-2955

On Oct 14, 2014, at 10:10 AM, ManicD <[hidden email]> wrote:

Can you point me in the right direction with this?
I did enable debug mode in the Settings > MailScanner Settings option and
have reviewed every log file i can find but I'm yet to find anything useful.



Also having a problem with low spam not being delivered even though the
domain setting says deliver.....might be my next topic but your help with
debugging may lead me on my way.



--
View this message in context: http://baruwa-users-list.963389.n3.nabble.com/Large-Delays-in-message-processing-for-Baruwa-2-0-Community-tp4027463p4027474.html
Sent from the Baruwa users list mailing list archive at Nabble.com.

_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056