Preview 502 Error

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Preview 502 Error

mrcrsn
Greetings Baruwa Community,

Kind of a bizarre issue.  When I first start my Baruwa server and click on preview message, it takes a long time then I get a 502 error from nginx.  After that I get nginx errors trying to access any part of the web interface.  I can get the interface back up by running "service uwsgi restart".   This problem persists with preview until I run "/etc/init.d/baruwa restart".  Then everything works fine.  Strange, no?

This behavior started when I moved the server from VirtualBox to Hyper-V.  Anyone have any ideas?

Thanks,

Marco

_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Preview 502 Error

mrcrsn
So I have poked around a bit on this.  Still don't see a solution to the issue.  If anyone has any ideas I would really appreciate it.


From: [hidden email]
To: [hidden email]
Date: Thu, 5 Sep 2013 09:45:34 -0500
Subject: [Baruwa] Preview 502 Error

Greetings Baruwa Community,

Kind of a bizarre issue.  When I first start my Baruwa server and click on preview message, it takes a long time then I get a 502 error from nginx.  After that I get nginx errors trying to access any part of the web interface.  I can get the interface back up by running "service uwsgi restart".   This problem persists with preview until I run "/etc/init.d/baruwa restart".  Then everything works fine.  Strange, no?

This behavior started when I moved the server from VirtualBox to Hyper-V.  Anyone have any ideas?

Thanks,

Marco

_______________________________________________ http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Preview 502 Error

jeremymcs
Disabled selinux ?

--
Jeremy McSpadden
Flux Labs, Inc | http://www.fluxlabs.net | Endless Solutions
Office : <a href="tel:850-250-5590;101" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="1">850-250-5590x101 | Cell : <a href="tel:850-890-2543" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="2">850-890-2543 | Fax : <a href="tel:850-254-2955" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="3">850-254-2955


On Sep 9, 2013, at 5:51 PM, "marco rosenstein" <[hidden email]> wrote:

So I have poked around a bit on this.  Still don't see a solution to the issue.  If anyone has any ideas I would really appreciate it.


From: [hidden email]
To: [hidden email]
Date: Thu, 5 Sep 2013 09:45:34 -0500
Subject: [Baruwa] Preview 502 Error

Greetings Baruwa Community,

Kind of a bizarre issue.  When I first start my Baruwa server and click on preview message, it takes a long time then I get a 502 error from nginx.  After that I get nginx errors trying to access any part of the web interface.  I can get the interface back up by running "service uwsgi restart".   This problem persists with preview until I run "/etc/init.d/baruwa restart".  Then everything works fine.  Strange, no?

This behavior started when I moved the server from VirtualBox to Hyper-V.  Anyone have any ideas?

Thanks,

Marco

_______________________________________________ http://pledgie.com/campaigns/12056
_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Preview 502 Error

jeremymcs
In reply to this post by mrcrsn
Have you checked your log files ? 

--
Jeremy McSpadden
Flux Labs, Inc | http://www.fluxlabs.net | Endless Solutions
Office : <a href="tel:850-250-5590;101" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="1">850-250-5590x101 | Cell : <a href="tel:850-890-2543" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="2">850-890-2543 | Fax : <a href="tel:850-254-2955" x-apple-data-detectors="true" x-apple-data-detectors-type="telephone" x-apple-data-detectors-result="3">850-254-2955


On Sep 9, 2013, at 5:51 PM, "marco rosenstein" <[hidden email]> wrote:

So I have poked around a bit on this.  Still don't see a solution to the issue.  If anyone has any ideas I would really appreciate it.


From: [hidden email]
To: [hidden email]
Date: Thu, 5 Sep 2013 09:45:34 -0500
Subject: [Baruwa] Preview 502 Error

Greetings Baruwa Community,

Kind of a bizarre issue.  When I first start my Baruwa server and click on preview message, it takes a long time then I get a 502 error from nginx.  After that I get nginx errors trying to access any part of the web interface.  I can get the interface back up by running "service uwsgi restart".   This problem persists with preview until I run "/etc/init.d/baruwa restart".  Then everything works fine.  Strange, no?

This behavior started when I moved the server from VirtualBox to Hyper-V.  Anyone have any ideas?

Thanks,

Marco

_______________________________________________ http://pledgie.com/campaigns/12056
_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Preview 502 Error

mrcrsn
Didn't see anything strange in the logs.  I restarted the server and went to preview a message running tail on the celeryd.log.  The issue didn't come up.   Restarted it 3 more times and couldn't recreate the issue.  You must be magic.


From: [hidden email]
To: [hidden email]
CC: [hidden email]
Date: Tue, 10 Sep 2013 00:55:56 +0000
Subject: Re: [Baruwa] Preview 502 Error

Have you checked your log files ? 

--
Jeremy McSpadden
Flux Labs, Inc | http://www.fluxlabs.net | Endless Solutions
Office : 850-250-5590x101 | Cell : 850-890-2543 | Fax : 850-254-2955


On Sep 9, 2013, at 5:51 PM, "marco rosenstein" <[hidden email]> wrote:

So I have poked around a bit on this.  Still don't see a solution to the issue.  If anyone has any ideas I would really appreciate it.


From: [hidden email]
To: [hidden email]
Date: Thu, 5 Sep 2013 09:45:34 -0500
Subject: [Baruwa] Preview 502 Error

Greetings Baruwa Community,

Kind of a bizarre issue.  When I first start my Baruwa server and click on preview message, it takes a long time then I get a 502 error from nginx.  After that I get nginx errors trying to access any part of the web interface.  I can get the interface back up by running "service uwsgi restart".   This problem persists with preview until I run "/etc/init.d/baruwa restart".  Then everything works fine.  Strange, no?

This behavior started when I moved the server from VirtualBox to Hyper-V.  Anyone have any ideas?

Thanks,

Marco

_______________________________________________ http://pledgie.com/campaigns/12056
_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________ http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056
Reply | Threaded
Open this post in threaded view
|

Re: Preview 502 Error

mrcrsn
So I was able to make it do it again.  Logs just show celeryd shutting down, like it was told to or something.  Works fine after restarting it.

[2013-09-11 15:58:12,858: DEBUG/MainProcess] Task accepted: preview-message[a83340f2-8ff5-4ff1-8e23-6dbf1ec3c8a9] pid:6339
[2013-09-11 15:58:13,530: INFO/PoolWorker-2] preview-message[a83340f2-8ff5-4ff1-8e23-6dbf1ec3c8a9]: Preview of message: 8656381F49.AD32F requested by user:
[2013-09-11 15:58:14,411: INFO/MainProcess] Task preview-message[a83340f2-8ff5-4ff1-8e23-6dbf1ec3c8a9] succeeded in 1.62543296814s: {'headers': {'date': u'Wed, 11 Sep 2013...
[2013-09-11 16:00:16,933: DEBUG/Beat] Celerybeat: Waking up in 5.00 minutes.
[2013-09-11 16:01:21,042: WARNING/MainProcess] celeryd: Warm shutdown (MainProcess)
[2013-09-11 16:01:21,061: DEBUG/MainProcess] Stopping thread Consumer...
[2013-09-11 16:01:21,061: DEBUG/MainProcess] Consumer: Stopping consumers...
[2013-09-11 16:01:21,104: DEBUG/MainProcess] Stopping thread _Process...
[2013-09-11 16:01:21,205: INFO/MainProcess] Celerybeat: Shutting down...
[2013-09-11 16:01:21,219: DEBUG/MainProcess] Stopping thread Timer...
[2013-09-11 16:01:21,265: DEBUG/MainProcess] Stopping thread TaskPool...
[2013-09-11 16:01:21,282: DEBUG/MainProcess] closing pool
[2013-09-11 16:01:21,453: DEBUG/MainProcess] worker handler exiting
[2013-09-11 16:01:21,460: DEBUG/MainProcess] task handler got sentinel
[2013-09-11 16:01:21,460: DEBUG/MainProcess] task handler sending sentinel to result handler
[2013-09-11 16:01:21,473: DEBUG/MainProcess] task handler sending sentinel to workers
[2013-09-11 16:01:21,473: DEBUG/MainProcess] task handler exiting
[2013-09-11 16:01:21,473: DEBUG/MainProcess] result handler got sentinel
[2013-09-11 16:01:21,473: DEBUG/MainProcess] ensuring that outqueue is not full
[2013-09-11 16:01:21,474: DEBUG/MainProcess] result handler exiting: len(cache)=0, thread._state=0
[2013-09-11 16:01:21,488: DEBUG/MainProcess] joining worker handler
[2013-09-11 16:01:21,489: DEBUG/MainProcess] joining task handler
[2013-09-11 16:01:21,489: DEBUG/MainProcess] joining result handler
[2013-09-11 16:01:21,489: DEBUG/MainProcess] result handler joined
[2013-09-11 16:01:21,504: DEBUG/MainProcess] joining worker 0/1 (<Process(PoolWorker-2, started daemon)>)
[2013-09-11 16:01:21,475: DEBUG/PoolWorker-2] worker got sentinel -- exiting
[2013-09-11 16:01:21,506: DEBUG/PoolWorker-2] worker exiting after 22 tasks
[2013-09-11 16:01:21,520: INFO/PoolWorker-2] process shutting down
[2013-09-11 16:01:21,520: DEBUG/PoolWorker-2] running all "atexit" finalizers with priority >= 0
[2013-09-11 16:01:21,521: DEBUG/PoolWorker-2] running the remaining "atexit" finalizers
[2013-09-11 16:01:21,522: INFO/PoolWorker-2] process exiting with exitcode 0
[2013-09-11 16:01:22,213: DEBUG/MainProcess] Consumer: Closing consumer channel...
[2013-09-11 16:01:22,287: DEBUG/MainProcess] Closed channel #1
[2013-09-11 16:01:22,289: DEBUG/MainProcess] Consumer: Closing broadcast channel...
[2013-09-11 16:01:22,548: DEBUG/MainProcess] Closed channel #2
[2013-09-11 16:01:22,665: DEBUG/MainProcess] Consumer: Closing broker connection...
[2013-09-11 16:01:22,679: DEBUG/MainProcess] Closed channel #3
[2013-09-11 16:01:22,921: INFO/MainProcess] process shutting down
[2013-09-11 16:01:22,921: DEBUG/MainProcess] running all "atexit" finalizers with priority >= 0
[2013-09-11 16:01:22,927: DEBUG/MainProcess] finalizing pool
[2013-09-11 16:01:22,927: DEBUG/MainProcess] helping task handler/workers to finish
[2013-09-11 16:01:22,927: DEBUG/MainProcess] removing tasks from inqueue until task handler finished
[2013-09-11 16:01:22,929: DEBUG/MainProcess] terminating workers
[2013-09-11 16:01:22,929: DEBUG/MainProcess] joining task handler
[2013-09-11 16:01:22,929: DEBUG/MainProcess] joining result handler
[2013-09-11 16:01:22,929: DEBUG/MainProcess] joining timeout handler



From: [hidden email]
To: [hidden email]
Date: Tue, 10 Sep 2013 10:18:18 -0500
Subject: Re: [Baruwa] Preview 502 Error

Didn't see anything strange in the logs.  I restarted the server and went to preview a message running tail on the celeryd.log.  The issue didn't come up.   Restarted it 3 more times and couldn't recreate the issue.  You must be magic.


From: [hidden email]
To: [hidden email]
CC: [hidden email]
Date: Tue, 10 Sep 2013 00:55:56 +0000
Subject: Re: [Baruwa] Preview 502 Error

Have you checked your log files ? 

--
Jeremy McSpadden
Flux Labs, Inc | http://www.fluxlabs.net | Endless Solutions
Office : 850-250-5590x101 | Cell : 850-890-2543 | Fax : 850-254-2955


On Sep 9, 2013, at 5:51 PM, "marco rosenstein" <[hidden email]> wrote:

So I have poked around a bit on this.  Still don't see a solution to the issue.  If anyone has any ideas I would really appreciate it.


From: [hidden email]
To: [hidden email]
Date: Thu, 5 Sep 2013 09:45:34 -0500
Subject: [Baruwa] Preview 502 Error

Greetings Baruwa Community,

Kind of a bizarre issue.  When I first start my Baruwa server and click on preview message, it takes a long time then I get a 502 error from nginx.  After that I get nginx errors trying to access any part of the web interface.  I can get the interface back up by running "service uwsgi restart".   This problem persists with preview until I run "/etc/init.d/baruwa restart".  Then everything works fine.  Strange, no?

This behavior started when I moved the server from VirtualBox to Hyper-V.  Anyone have any ideas?

Thanks,

Marco

_______________________________________________ http://pledgie.com/campaigns/12056
_______________________________________________
http://pledgie.com/campaigns/12056

_______________________________________________ http://pledgie.com/campaigns/12056

_______________________________________________ http://pledgie.com/campaigns/12056

_______________________________________________
http://pledgie.com/campaigns/12056